EyeMed Claims Payer Processing Interruption

Incident Report for Ensora Clearinghouse

Resolved

This issue is persisting, but it is a connectivity issue occurring downstream of our systems. Our systems are fully operational.
Posted Dec 03, 2025 - 11:38 MST

Update

This issue is persisting, but it is a connectivity issue occurring downstream of our systems. Our systems are fully operational.
Posted Dec 03, 2025 - 11:37 MST

Monitoring

This issue is persisting, but it is a connectivity issue occurring downstream of our systems. Our systems are fully operational.
Posted Dec 03, 2025 - 11:36 MST

Update

This issue is persisting, but it is a connectivity issue occurring downstream of our systems. Our systems are fully operational.
Posted Dec 03, 2025 - 11:35 MST

Identified

Important Update for EYEMED providers: How to Submit Your Vision Claims

Due to a widespread connectivity issue with EyeMed, we want to ensure you have the most accurate and efficient options for submitting your vision claims.

Electronic submission options:
For In-Network Providers - In-network providers can submit claims electronically through the EyeMed Provider Website: https://www.eyemed.com/en-us/provider

This is the fastest and most efficient method and does not require third-party software.
Providers should confirm that their provider portal access is fully set up with the payer before submitting claims.

For Members Using Out-of-Network Providers - If you received services from an out-of-network provider, you can request reimbursement using one of the following methods:

- Online Submission - Submit an electronic claim form through your Member Web account.
- Mail, Fax, or Email - Send your completed claim form and itemized paid receipts to:

Mail:
First American Administrators, Inc.
Attn: OON Claims
P.O. Box 8504
Mason, OH 45040-7111

Fax: 866-293-7373
Email: oonclaims@eyemedvisioncare.com

Submitting Through Us - You may still choose to submit your claim through our office.

However, please note:
- Claims submitted through us will be processed as paper claims.
- Paper claim processing fees apply.
- Processing times may be longer compared to direct electronic submission.

For the fastest reimbursement, we encourage using the electronic options listed above.
Posted Dec 03, 2025 - 11:34 MST
This incident affected: Partner Integration.